RE: [PHP] FreeBSD 4.6 / PHP 4.2.2 / Apache 2.0.39 install trouble
| From: | Chad Day | Date: | Thu, 25 Jul 2002 18:54:49 +0000 |
| Subject: | RE: [PHP] FreeBSD 4.6 / PHP 4.2.2 / Apache 2.0.39 install trouble | ||
| References: | 1 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-109572@lists.php.net to get a copy of this message | ||
The apache configure line was a vanilla configure, only turning on
mod_rewrite and enabling so.
It's really as basic of a configure as I could do.. I don't understand why
it failed. :(
So I did what someone else suggested, tried the ports.. installed apache2,
fine, tried to install mod_php4, selected zlip, mysql, + openldap2.x
support. Got the packages, then when installing them and it got to apxs, it
was looking for --with-apxs2 since apache 2.x is being used. apparently the
script used --with-apxs. I don't see where I can change this.
Unreal that this is this difficult to get working. :\
Chad
-----Original Message-----
From: Tech Support [mailto:jgrill@web-1hosting.net]
Sent: Thursday, July 25, 2002 2:49 PM
To: Chad Day
Subject: Re: [PHP] FreeBSD 4.6 / PHP 4.2.2 / Apache 2.0.39 install
trouble
Without seeing exactly what steps you took in building both apache and php
it would be next to impossible to guess.
Jim Grill
Support
Web-1 Hosting
http://www.web-1hosting.net
----- Original Message -----
From: "Chad Day" <cday@atpco.com>
To: "Tech Support" <jgrill@web-1hosting.net>
Sent: Thursday, July 25, 2002 12:53 PM
Subject: RE: [PHP] FreeBSD 4.6 / PHP 4.2.2 / Apache 2.0.39 install trouble
> Ok, I decided to revert back to 1.3.26.
>
> PHP builds fine..
>
> When I go to start Apache:
>
> Syntax error on line 205 of /usr/local/www/conf/httpd.conf:
> Cannot load /usr/local/www/libexec/libphp4.so into server:
> /usr/local/www/libexec/libphp.so: Undefined symbol "core_globals"
>
> What does that mean? Google turned up 4 results, none relevant, php.net
> search turned up 0.
>
> Thanks,
> Chad
>
> -----Original Message-----
> From: Tech Support [mailto:jgrill@web-1hosting.net]
> Sent: Thursday, July 25, 2002 1:16 PM
> To: Chad Day; php-general@lists.php.net
> Subject: Re: [PHP] FreeBSD 4.6 / PHP 4.2.2 / Apache 2.0.39 install
> trouble
>
>
> 4.2.2 will not work with apache 2.X from what I've read. However, I have
> heard that if you get the latest CVS of both php and apache it will work.
I
> have not, and probably will not, go down that road just yet :-)
>
> Jim Grill
> Support
> Web-1 Hosting
> http://www.web-1hosting.net
> ----- Original Message -----
> From: "Chad Day" <cday@atpco.com>
> To: <php-general@lists.php.net>
> Sent: Thursday, July 25, 2002 11:38 AM
> Subject: [PHP] FreeBSD 4.6 / PHP 4.2.2 / Apache 2.0.39 install trouble
>
>
> > Simple build, no real complicated configure options
> > (--with-mysql, --with-apxs2..) ..
> >
> > During make:
> >
> > php_functions.c:93: syntax error
> > *** Error code 1
> >
> > Stop in /usr/local/php-4.2.2/sapi/apache2filter.
> >
> > etc
> > etc
> >
> >
> > Any idea what the problem would be? I googled around for a little and
> heard
> > there might be problems getting the latest php to work with apache
2.0.39,
> > but that was a couple weeks ago.. I thought the new 4.2.2 build might
> > address it, but I guess if it's only a security fix like the site says,
> > maybe not.. does 4.2.* just not work with Apache 2.0.39, or is something
> > else amiss?
> >
> > Thanks,
> > Chad
> >
> >
> > --
> > PHP General Mailing List (http://www.php.net/)
> > To unsubscribe, visit: http://www.php.net/unsub.php
> >
> >
> >
>
>
>
> --
> PHP General Mailing List (http://www.php.net/)
> To unsubscribe, visit: http://www.php.net/unsub.php
>
>
>
>