Re: I'm cracking up!

From: Date: Thu, 01 Jan 1970 00:00:00 +0000
Subject: Re: I'm cracking up!
References: 1  Groups: php.general 
Request: Send a blank email to php-general+get-11782@lists.php.net to get a copy of this message
Hi, OK so Ive given up on creating a static module for apache and gone for the DSO approach. directory source tree: apache: /var/lib/apache php : /usr/local/php mysql : /usr/local/mysql-3.22.32 Install: 1. gunzip -c php*.gz | tar xf - 2. cd php* 3. ./configure --with-apxs=/var/lib/apache/sbin/apxs \ --with-mysql=/usr/local/mysql \ --with-system-regex 4. make 5. make install 6. edit /var/lib/apache/conf/httpd.conf "LoadModule php4_module libexec/libphp4.so" "AddModule mod_php4.so" were already added so I just uncommented: "AddType application/x-httpd-php .php" "AddType application/x-httpd-php-source .phps" 7. check apache: /var/lib/apache/sbin/apachectl configtest I get the following error: apachectl: Syntax error on line 238 of var/lib/apache/conf/httpd.conf Cannot load /var/lib/apache/libexec/libphp4.so into server: libmysqlclient.so.6: Cannot open shared object file: no such file or directory. Umm. Well Ive told php where mysql is in the config above. So there must be a library file somewhere in php pointing at the file but in the wrong directory.. The libphp4.so exists and so does libmysqlclient.so.6 (which is a symlink to libmysqlclient.so.0.0.6 -- in directory /usr/local/mysql-3.22.32/lib/) How can I get php to find this file as I think that PHP thinks that the libmysqlclient.so.6 file is in /var/lib/apache/libexec/ or has the libmysqlclient.so.6 got incorrect permissions for others to use it. Cheers Paul On Tue, 15 Aug 2000 13:14:53 +0200 ibrahim@infinito.it wrote: > Hi All, > > > I had lot of errors compiling Apache/PHP and to make it work. > > I use Suse 6.4 and yesterday I could make it this way.<bold> > > > </bold>With apache I uses<color><param>3200,3200,3200</param> > > ./configure --prefix=/my/apache/path --enable-module=most > > --enable-shared=max > > make > > make install > > > With Php > > > ./configure --with-apxs=/usr/local/apache/bin/apxs > > make > > make install > > > "/usr/local/apache/bin/apxs" is the path to the apache apxs. > > > > </color>I added > > LoadModule php4_module libexec/libphp4.so > > > and > > > AddModule mod_php4.c > > > to my httpd.conf > > > and you shall remember to add/activate in the httpd.conf file in the > "<<IfModule mod_mime.c>" section > > the following > > > AddType application/x-httpd-php .php .php4 .php3 .phtml > > AddType application/x-httpd-php-source .phps > > > > I hope this will help > > > Ibrahim > > > > > <color><param>7F00,0000,0000</param>> Hi, > > > > > > This is one of many attempts at trying to get PHP installed and it still doesnt > > > work.. Can anyone help!!!!!!!!!!! Please.. Im losing my marbles... > > > Im installing php4.0.1pl2 onto linux slackware 7.1 with mysql-3.22.32. > > > > > > > > > source directories:: > > > > > > apache: /var/lib/apache (already installed) > > > mysql : /usr/local/mysql-3.22.32 > > > php4 : /var/lib/php-4.0.1pl2 > > > > > > > > > > > > Install procedure:: > > > > > > > > > 1. stop apache: /var/lib/apache/bin/apachectl stop > > > 2. cd /var/lib/apache > > > 3. ./configure --prefix=/var/lib/apache > > > 4. cd ../php* > > > 5. ./configure \ > > > --with-mysql=/usr/local/mysql-3.22.32 \ > > > --with-xml \ > > > --with-apache=/var/lib/apache \ > > > --enable-track-vars > > > 6. make > > > 7. make install > > > 8. cp php.ini-dist /usr/local/lib/php.ini > > > 9. cd /var/lib/apache > > > 10. ./configure \ > > > --activate-module=src/modules/php4/libphp4.a \ > > > --enable-module=php4 \ > > > --prefix=/var/lib/apache > > > 11. make > > > 12. make install > > > 13. uncomment httpd.conf commands > > > "AddType application/x-httpd-php .php" > > > "AddType application/x-httpd-php-source .phps" > > > 14. cp /var/lib/apache/src/httpd /var/lib/apache/bin/httpd > > > 15. restart server /var/lib/apache/bin/apachectl start > > > > > > > > > OK at this point there are no errors in compiling. however when i test a .php > > > document Im prompted to save the file. > > > > > > 16. Ive checked that the module has been complied and when I do : > > > root@var/lib/apache/bin> httpd -l > > > the list contains : mod_php4.c > > > > > > 17. And when I check the apache compile : > > > ./apachectl configtest > > > I get : syntax OK > > > > > > 18. I try restarting apache > > > ./apachectl restart > > > error report: "httpd not running, trying to restart" > > > "httpd started" > > > > > > 19. So I decided to stop the server and > > > ./apachectl stop > > > error report: "httpd (no pid file) not running" > > > > > > yet when I look at localhost the server is still up???? > > > > > > Can anyone help? > > > > > > cheers in advance > > > > > > Paul > > > > > > > > > -------------------------------------- > > > Paul Hooper > > > IT Support > > > > > > Anglia Polytechnic University > > > Library Systems Office, > > > East Road, > > > Cambridge. > > > CB1 1PT > > > > > > Tel: +44 (0)1223 363271 Ext.2305 > > > E-Mail: paul.a.hooper@anglia.ac.uk > > > -------------------------------------- > > > > > > > > > -- > > > PHP Install Mailing List (http://www.php.net/) > > > To unsubscribe, e-mail: php-install-unsubscribe@lists.php.net > > > For additional commands, e-mail: php-install-help@lists.php.net > > > To contact the list administrators, e-mail: php-list-admin@lists.php.net > > > > > > > <nofill> -------------------------------------- Paul Hooper IT Support Anglia Polytechnic University Library Systems Office, East Road, Cambridge. CB1 1PT Tel: +44 (0)1223 363271 Ext.2305 E-Mail: paul.a.hooper@anglia.ac.uk --------------------------------------

« previous php.general (#11782) next »