Re: *OK, more eval for today

From: Date: Wed, 18 Dec 2002 19:28:36 +0000
Subject: Re: *OK, more eval for today
References: 1 2  Groups: php.general 
Request: Send a blank email to php-general+get-128765@lists.php.net to get a copy of this message
Okay, wait. How? say, I have a field of checkboxes in 3 columns and 6 rows. I need at least one checked. At the moment every checkbox has the name of kind: q3_4_1 , where 4 stands for row and 1 for column. Now, how do I name them and loop through them? Plus, if $HTTP_POST_VAR["q3_4_1"] wasn't checked at all, the value is not passed over, right? So I get... null, I believe. So with my eval I first do if(isset()) and then go on. How would I I behave in your case? Please, John, if you could be even more specific?.... Sweating Alex "John W. Holmes" <holmes072000@charter.net> wrote in message news:001e01c2a6ca$22310e00$7c02a8c0@coconut... > Why not name your form elements php_q3[] and then just loop through the > array. That would cut the need for eval(). > > ---John W. Holmes... > > PHP Architect - A monthly magazine for PHP Professionals. Get your copy > today. http://www.phparch.com/ > > > -----Original Message----- > > From: Alexey Lysenkov [mailto:man@xtati.com] > > Sent: Wednesday, December 18, 2002 2:08 PM > > To: php-general@lists.php.net > > Subject: [PHP] *OK, more eval for today > > > > I know, it's eval = evil, but I don't see any other way I can check > for > > 120 variables submitted via post, without making a temp variable, > > assigning a value of the posted Var and checking for it (and deciding > on > > the further run of the script). Anyways, I took a classical eval thing > and > > am doing fine with it. It looks like this: > > > > $temp = "\$php_q3_".$i; // $i is a loop index > > eval ("\$temp = \"$temp\";"); > > > > works alright. Now, how do I eval directly from the $HTTP_POST_VARS? > > > > I am trying to do this: > > > > $tempVar1 = '\$HTTP_POST_VARS[\"q4_'.$i.'"]'; > > eval("\$tempVar1=\"$tempVar1\";"); > > > > and am obviously failing. If you know any other way to validate > 120-150 > > variables in a loop and then rewrite the values into the fields > > (checkboxes, radios and selects) - should an error had been made - let > me > > know. > > > > Best Regards, > > Alex > > > > p.s. you do help! :) > >

« previous php.general (#128765) next »