Re: FOR, FOREACH, and Input Box Names
| From: | Guru Geek | Date: | Fri, 25 Apr 2003 20:30:26 +0000 |
| Subject: | Re: FOR, FOREACH, and Input Box Names | ||
| References: | 1 2 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-145312@lists.php.net to get a copy of this message | ||
WOW. That was simple enough. I was reading reference upon reference about
concatenation and stuff. Some times the simplest is the best. Thanks a lot
for you tip/suggestion!
Thanks,
Roger
Brian Cressall wrote:
> You can change the name of the estimatedGrade text box by appending your
> loop variable (boxCreator). This way each text box has its own unique
> name. Example:
>
> echo "<input type='text'
> name='creditBox$boxCreator'>";
>
> You may also want to continue to pass your $numberCourses value with the
> form (as a hidden variable) so the next page will now how many variables
> to work with.
>
> On Fri, 2003-04-25 at 14:10, Guru Geek wrote:
> > rest of the program will work with these two values extensively. How
> > can I individualize the name of each creditBox? That is to say, how can
> > I keep the value entered inside the creditBox in row one seperate from
> > the value entered inside the creditBox on line 4 (assuming there is a
> > line 4). I use a FOR statement to draw my table based on the amount of
> > courses being taken.
> >
>
> --
> Brian Cressall <brian@onlineitools.com>