Re: PHP CLI question

From: Date: Thu, 05 Jun 2003 14:53:42 +0000
Subject: Re: PHP CLI question
References: 1 2 3  Groups: php.general 
Request: Send a blank email to php-general+get-150366@lists.php.net to get a copy of this message
>From a ./php -h: -c <path>|<file> Look for php.ini file in this directory The "|" means "OR", so logic would dictate you can point directly to the file with the -c option. On Thu, 2003-06-05 at 10:35, Monte Ohrt wrote: > Hi Cal, > > I may be missing something, but I don't see how this page answers either > of my questions. ini_set() is for setting configuration options. > > Monte > > On Thu, 2003-06-05 at 09:23, Cal Evans wrote: > > http://www.php.net/manual/en/function.ini-set.php > > > > * Cal Evans > > * http://www.christianperformer.com > > * Stay plugged into your audience > > * The measure of a programmer is not the number of lines of code he writes > > but the number of lines he does not have to write. > > * > > > > ----- Original Message ----- > > From: "Monte Ohrt" <monte@ispi.net> > > To: <php-general@lists.php.net> > > Cc: <php-dev@lists.php.net> > > Sent: Thursday, June 05, 2003 9:22 AM > > Subject: [PHP] PHP CLI question > > > > > > > Hi, > > > > > > A couple of questions: > > > > > > 1) Is there a way to make the CLI version of PHP ignore certain settings > > > in the php.ini file? For instance, I don't want the ioncube accelerator > > > invoked when using PHP from the command line. My current work around is > > > to use two separate init files, php.ini and php-cli.ini ... and this > > > brings me to my second question: > > > > > > 2) Is there a way to specify a different name for the php.ini file, > > > apart from hacking php_ini.c ? It seems I can only change the _path_ to > > > the file, but not the filename itself. > > > > > > TIA > > > Monte > > > > > > > > > > > > -- > > > PHP General Mailing List (http://www.php.net/) > > > To unsubscribe, visit: http://www.php.net/unsub.php > > > > > > -- Adam Voigt (adam@cryptocomm.com) Linux/Unix Network Administrator The Cryptocomm Group

« previous php.general (#150366) next »