weird issues w/PHP install
| From: | Michael Geier | Date: | Wed, 02 Jul 2003 16:10:50 +0000 |
| Subject: | weird issues w/PHP install | ||
| Groups: | php.general | ||
| Request: | Send a blank email to php-general+get-153725@lists.php.net to get a copy of this message | ||
I have installed PHP numerous times using the same configuration and
this is the first time I have run into this issue.
solaris 2.8 on e3500
apache 1.3.27 ( --enable-module=so --prefix=/usr/local/apache)
php 4.3.2 ( --with-apxs
--with-mysql
--with-mssql=/usr/local/freetds
--enable-ftp
--with-mcrypt=/usr/local
--with-pear
--with-zlib )
mcrypt, freetds both installed fine
installation of PHP is fine
attempt to restart apache give:
Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: ld.so.1:
/usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/apache/libexec/libphp4.so: symbol ap_block_alarms: referenced
symbol not found
Google of this error returns some issues with zlib around the php 4.0 -
4.2 versions.
any thoughts would be extremely helpful.
mike