RE: [PHP] PHP as ErrorDocuments (Apache)

From: Date: Wed, 06 Sep 2000 09:12:55 +0000
Subject: RE: [PHP] PHP as ErrorDocuments (Apache)
Groups: php.general 
Request: Send a blank email to php-general+get-15476@lists.php.net to get a copy of this message
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Upgrading to 4.0.2 does seem to have resolved the situation. Thank you Rasmus, Regards, Ollie - -------------------------------------------- Ollie Cook +44 (7946) 057 198 PGP: http://ollie.zenox.dhs.org/pgp-key - -------------------------------------------- > -----Original Message----- > From: Rasmus Lerdorf [mailto:rasmus@php.net] > Sent: 06 September 2000 00:36 > To: o.cook@etoncollege.org.uk > Cc: php-general@lists.php.net > Subject: Re: [PHP] PHP as ErrorDocuments (Apache) > > > Please try PHP 4.0.2. I fixed some things between 4.0.0 and > 4.0.2 that > might affect you. > > -Rasmus > > On Wed, 6 Sep 2000 o.cook@etoncollege.org.uk wrote: > > > I'm having a little trouble with using PHP scripts as > ErrorDocuments, but > > I'm not sure where I'm slipping up. > > > > For example - I have the following in my .htaccess file: > > > > <Files "config.inc.php"> > > order deny,allow > > deny from all > > </Files> > > <Files "diary_admin.php"> > > AuthUserFile /home/ollie/htpasswd > > AuthGroupFile /dev/null > > AuthName "Diary Admin" > > AuthType Basic > > <Limit GET POST> > > require valid-user > > </Limit> > > </Files> > > ErrorDocument 401 /forbidden.php > > ErrorDocument 404 /missing.php > > > > If I go to http://site.com/non-existant then I get > missing.php - which > > parses correctly - great! > > > > However, if I go to http://site.com/diary_admin.php I get > forbidden.php, > > parsed correctly, before I'm even prompted for a username > and password. > > Sometimes, however, it works. I tried clearing the cache > etc. but that > > didn't seem to help. > > > > Can anyone see an obvious mistake that I'm making? For > information: Server > > Version: Apache/1.3.12 (Unix) PHP/4.0.0 > > > > Ollie > > > > P.S. I'm aware that 401 is actually "Authorization > Required" and that 403 is > > "Forbidden", but am just to lazy to rename the file! :) > > > > -------------------------------------------- > > Ollie Cook +44 (7946) 057 198 > > PGP: http://ollie.zenox.dhs.org/pgp-key > > -------------------------------------------- > > > > > > > -- > PHP General Mailing List (http://www.php.net/) > To unsubscribe, e-mail: php-general-unsubscribe@lists.php.net > For additional commands, e-mail: php-general-help@lists.php.net > To contact the list administrators, e-mail: > php-list-admin@lists.php.net > -----BEGIN PGP SIGNATURE----- Version: PGPfreeware 6.5.8 for non-commercial use <http://www.pgp.com> iQA/AwUBObYKl8PaWaNT0pVnEQIy2gCfZfrXnRgEXzOlVO8IpgZtXqJipyIAoJxv lLhL3rx+U15jFlrgmpnuQjhD =yoY3 -----END PGP SIGNATURE-----

« previous php.general (#15476) next »