Virtual Host/SuExec/PHP CGI prob
| From: | anthony at cosmic dot net dot au | Date: | Wed, 13 Sep 2000 16:55:48 +0000 |
| Subject: | Virtual Host/SuExec/PHP CGI prob | ||
| Groups: | php.general | ||
| Request: | Send a blank email to php-general+get-16605@lists.php.net to get a copy of this message | ||
Hello,
I have been looking into the possible ways to run php as like a userid
as per the perl/suexec method.
I have many questions as I am concerned about security foremost.
1) Is running php as a CGI Binary the only possible way to get suexec
like security/userid functionality?.
2) Does anyone know what sort of performance drag running php as CGI
Binary creates?
3) Problem with testing CGI Binary, without any Suexec stuff involved
: On a Development box that already had php4 running, I decided to make
the CGI Binary of php.
I removed all php module configurations from the
httpd.conf and made a test.phtml in my cgi-bin.
Gave it o+x permissions..
The script as follows
#!/pathtophp/etc/php4/php
<?
echo "hello";
?>
I have checked the path.. and everything seems to be in order, but i get
the following error in my http error logs
cgi_main.c(279) : Freeing 0x0813093C (24 bytes), script=-
and the script from a web browser returns the error,
No input file specified.
I have not recompiled apache, if that is important to remove php module
stuff?:)
I guess it cant find my script file but I dont know why, maybe another
configuration option is needed.
Any answers to any of these questions would be greatly appreciated.
If anyone has succesfully setup suexec&cgi-bin&php-bin running as
individual users for different virtual hosts please give me some
direction.
Thanks
Anthony