php3_open_dir not quite restricted

From: Date: Sat, 16 Sep 2000 23:10:59 +0000
Subject: php3_open_dir not quite restricted
Groups: php.general php.general 
Request: Send a blank email to php-general+get-17094@lists.php.net to get a copy of this message
hi, I noticed that even php3_open_dir is specified for particular virtual host, one can still do e.g. filesize("/etc/passwd"). Shouldn't it be rejected like fopen() is? Do PHP4 behave same stupid way? If so, how can I work that around? Thanks. Regards, -- Win95: "We made it safe to turn off your computer" Marcin http://wfmh.org.pl/~carlos/ mailto:carlos@wfmh.org.pl

« previous php.general (#17094) next »