Re: combining two variables to make one???

From: Date: Mon, 22 Dec 2003 14:27:48 +0000
Subject: Re: combining two variables to make one???
References: 1  Groups: php.general 
Request: Send a blank email to php-general+get-173155@lists.php.net to get a copy of this message
Cheers... Doesn't work for me though...? What do the '{' mean when declaring the variable? "Chris Boget" <chris@wild.net> 22/12/2003 14:16 To <php-general@lists.php.net>, <Tristan.Pretty@risk.sungard.com> cc Subject Re: [PHP] combining two variables to make one??? > <? > $i = 1; > while ($i >= 3) { > $options$i = "result $i"; > } > ?> You want this: ${"$options{$i}"} = "result $i"; For the sake of clarity I typically do something like the following: $i = 1; while ($i >= 3) { $varName = $options . $i; ${$varName} = "result $i"; } Chris -- PHP General Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php ********************************************************************* The information contained in this e-mail message is intended only for the personal and confidential use of the recipient(s) named above. If the reader of this message is not the intended recipient or an agent responsible for delivering it to the intended recipient, you are hereby notified that you have received this document in error and that any review, dissemination, distribution, or copying of this message is strictly prohibited. If you have received this communication in error, please notify us immediately by e-mail, and delete the original message. ***********************************************************************

« previous php.general (#173155) next »