Re: Code elegance and cleanliness
| From: | Matthew Sims | Date: | Sat, 24 Jul 2004 03:00:42 +0000 |
| Subject: | Re: Code elegance and cleanliness | ||
| References: | 1 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-191722@lists.php.net to get a copy of this message | ||
> Just a quick question. Does it really matter how long your code is or how
> many variables you use? For instance you can enter the following...
>
> $imgBkgrnd = array("1"=> "bkgrnd-default.gif", "2" =>
> "bkgrnd-positive.gif", "3" => "bkgrnd-negative.gif");
> $imgNeeded = table['field'];
> $imgName = $imgBkgrnd[$imgNeeded];
>
> or, you can code the same thing as...
>
> $imgBkgrnd = array("1"=> "bkgrnd-default.gif", "2" =>
> "bkgrnd-positive.gif", "3" => "bkgrnd-negative.gif");
> $imgName = $imgBkgrnd[$table['field']];
>
> The first example uses one more variable and a longer code block but is
> easier to read and debug. The second example uses one less variable and a
> shorter code block but is harder to debug later. Should I be striving for
> the shortest most compact code utilizing the fewest possible variables.
> Or,
> can I code in a style which is easier to read and debug?
>
> --
> Robb Kerr
It depends. But in this case probably not. If I had several thousand lines
of code then perhaps yes. But go with the first as it's a hell of a lot
easier to read.
--
--Matthew Sims
--<http://killermookie.org>