critique this code please

From: Date: Sun, 02 Jan 2005 17:50:34 +0000
Subject: critique this code please
Groups: php.general 
Request: Send a blank email to php-general+get-205472@lists.php.net to get a copy of this message
i have this small function for a template system (if you want to call it that ;) my idea was having something simple to separate html code from php and i think using something like smarty is too big for me and i really dont have time to learn to use it. so i have this code here: http://www.cstrike-planet.com/function.phps i call this function which reads .tpl files which contain html and some $vars, then in my pages use something like: eval('echo("' . template('home_index') . '");'); unfortunaly my site has grown since and im not sure if this is causing an extra overhead on the site.. is there a way to 'improve' this small function? thanks for any help.

« previous php.general (#205472) next »