Error when starting iPlanet w/ PHP4
| From: | Lester June Cabrera | Date: | Tue, 17 Oct 2000 10:23:26 +0000 |
| Subject: | Error when starting iPlanet w/ PHP4 | ||
| References: | 1 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-20590@lists.php.net to get a copy of this message | ||
Hi,
I was able to install PHP4 w/ iPlanet w/o errors in Solaris platform. But after editing mime.types and obj.conf and restarting iPlanet, I got the following error:
conf_init: Error running init function load-modules: dlopen of /usr/netscape/ser
ver4/bin/libphp4.so failed (ld.so.1: ns-httpd: fatal: libstdc++.so.2.10.0: open
failed: No such file or directory)
Can somebody give me an idea on how to fix this problem?
To compile, I ran the following commands:
./configure --with-nsapi=<path of iPlanet> --enable-libgcc
make
make install
Then edit mime.types and ob.conf
#. add the ff line in mime.types
type=magnus-internal/x-httpd-php exts=php
# note place following two lines after mime types init!
Init fn="load-modules" funcs="php4_init,php4_close,php4_execute,php4_auth_trans" shlib="/usr/netscape/server/bin/libphp4.so"
Init fn=php4_init errorString="Failed to initialize PHP!"
<Object name="default">.
.
. # NOTE this next line should happen after all 'ObjectType' and before all 'AddLog' lines
Service fn="php4_execute" type="magnus-internal/x-httpd-php".
.
</Object>
<Object name="x-httpd-php">
ObjectType fn="force-type" type="magnus-internal/x-httpd-php"
Service fn=php4_execute
</Object>
Are these correct? I'm using GCC 2.95.2
Thanks,
Lester