Re: sql query
| From: | Jochem Maas | Date: | Thu, 03 Mar 2005 14:29:16 +0000 |
| Subject: | Re: sql query | ||
| References: | 1 2 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-209918@lists.php.net to get a copy of this message | ||
Jason Petersen wrote:
On Wed, 2 Mar 2005 13:02:39 +0200, William Stokes <kalles@operamail.com> wrote:in terms of readability an alternative if to write it like so: if(! ($variable = mysql_query("SELECT * FROM blah")) { // do stuff } what you have to realise is that the expression '$variable = mysql_query("SELECT * FROM blah")' has a return value itself - which just happens to be the same as the value of $variable. to put it another way, when you do: echo $variable; your not saying: "output the contents of this variable" but your actually saying: "output the result of the expression '$variable'" it just so happens that the result of the expression is this case if the contents of $variable. hopefully you get what I mean!, no doubt there are others that can explain it better!Hello Can someone explain this to me. I don't know how to read this. if (!$variable = mysql_query("select id,sessid from users where ... What is this "if(!"This is a way to run a SQL query, capture the return value, and perform an action if the query failed. For code readability, I would probably write that as two statements: $variable = mysql_query("SELECT * FROM blah"); if(!$variable) { error_handler(mysql_error()); }
See the documentation for information on mysql_query return values: http://us2.php.net/manual/en/function.mysql-query.php Jason