Re: using ($test)?$true:$false in a string
| From: | Richard Heyes | Date: | Mon, 21 Nov 2005 15:02:21 +0000 |
| Subject: | Re: using ($test)?$true:$false in a string | ||
| References: | 1 2 3 4 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-226200@lists.php.net to get a copy of this message | ||
Robert Cummings wrote:
On Mon, 2005-11-21 at 09:42, Chris Boget wrote:Readability is in the eye of the beholder. -- Richard Heyes http://www.phpguru.orgThat's like using a bulldozer to tidy your living room. Why not use the following even more readable style (and more efficient)? $outputStr =That is so totally slick! I'm definitely going to have to remember this neat little trick! :)and I feel it would be more elegant to be able to do something like: $var ="first part of string {(($a==$b)?$c:$d)} rest of string";$templateStr = 'first part of string %s rest of string'; $outputStr = sprintf($templateStr, (($a==$b)?$c:$d));'first part of string '.($a == $b ? $c : $d) .' rest of string';