IF or SWITCH

From: Date: Thu, 06 Apr 2006 02:48:22 +0000
Subject: IF or SWITCH
Groups: php.general 
Request: Send a blank email to php-general+get-233321@lists.php.net to get a copy of this message
Hello World! wait, not coding... (sorry, long night) Okay, I finally finished hashing out all the logic for a very complex set of rules to determine what "type" an application should be set to. I won't bore you with the details of it, but the question is... I have 57 if/elseif/else statements because of all the different criteria. Is it considered better programming practice to use if/elseif/else statements over a switch(true) case (true && false || true || false) syntax? Basically, I'm not too happy with the readability of the code, but I'm afraid that at this point there's not much I can do... code snippet: if($numFFELP > 1 && count($FFELP_Lenders) > 1 && $numFFELP == $numTotal){ $retVal = array(TRUE, 'A'); }elseif($numFFELP > 0 && $enumFFELP > 0 && count($FFELP_Lenders) > 1 && $enumFFELP + $numFFELP == $numTotal){ $retVal = array(TRUE, 'A'); }elseif($numFFELP > 0 && $numCONS > 0 && count($FFELP_Lenders) > 1 && $numFFELP + $numCONS == $numTotal){ etc. Any suggestions? Thanks, -- Ray Hauge Programmer/Systems Administrator American Student Loan Services www.americanstudentloan.com 1.800.575.1099

« previous php.general (#233321) next »