Re: Help!
| From: | Martin Alterisio | Date: | Sat, 29 Apr 2006 05:28:28 +0000 |
| Subject: | Re: Help! | ||
| References: | 1 2 3 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-235057@lists.php.net to get a copy of this message | ||
2006/4/28, Barry <barry@flyerheaven.de>:
Martin Alterisio schrieb: 2006/4/28, Dave Goodchild <buddhamagnet@gmail.com>:Yeah you're right, I was thinking the exact same thing a while after I posted that. Maybe it was a correct name in the context used, but, I still think "Santa" is a really misleading name for a mailer, and not to mention that a mass mailer identifying itself as "Santa mailer" in the headers is asking to be send directly to spam. Anyway, I was wrong.wouldHi all - I am attempting to solve some maddening behaviour that has me totally stumped and before I take a blade to my throat I thought Iemailspick the brains of the group/hive/gang. I am working on a viral marketing application that uses multipartsanityto notify entrants of their progress in the 'game'. I have a demo version which works fine, and the current rebranded version was also fine until the client asked for some changes then POWWWWW! I will try and define the issue as simply as I can. I am passing 11 arguments to a function called sendSantaMail (don't ask) and as aarecheck I have called mail() to let me know the values just before theysendSantaMail???? That's just not a *declarative* way of naming a function. Do you know what "santa" means? No? so how can you tell it's not declarative. Santa could be a coded Mailer and that functions uses that specific Mailer Deamon called "santa" to send mails.passed in to the function. I get this result:
Then, 11 arguments???? Errr, passing an associative array with the email parameters wouldn't have been a cleaner and better option? He just told he passes 11 arguments, never told how he does that.Well, if somebody tells you a function has 11 arguments what would you think?