final error??
| From: | Russell John Michell | Date: | Thu, 01 Jan 1970 00:00:00 +0000 |
| Subject: | final error?? | ||
| Groups: | php.general | ||
| Request: | Send a blank email to php-general+get-24130@lists.php.net to get a copy of this message | ||
Hi there:
I'm currently attempting a php4 installl (php-4.0.1pl2)
on Red-Hat 6.1 with apache-1.3.12.
I have a successfully installed mysql-3.22.32.
PHP4 has been installed thus far according to the following procedure:
1. gunzip php-4.0.1pl2
2. tar -xvf php-4.0.1pl2
3. ./configure--with-apxs=/usr/lib/apache/bin/apxs \
--with-mysql=/usr/local/mysql-3.22.32 \
--with-system-regex
4. make
5. make install
6. edited apache's httpd.conf, uncommented
AddType-application/x=-httpd-php .php etc etc
However upon checking 'LoadModule' section, php4 had been added as
follows:
1. LoadModule php_module libexec/libphp4.so
(No other modules were in this section)
The AddModule section wasn't included in apache's httpd.conf file, so
we added it as follows:
1. ClearModuleList mod_php4.c
We then attempted to restart apache, and the following is what we did
and what occured after:
[root@gertrude apache]# ./bin/apachectl restart
./bin/apachectl restart: configuration broken, ignoring restart
./bin/apachectl restart: (run 'apachectl configtest' for details)
[root@gertrude apache]# apachectl configtest
bash: apachectl: command not found
[root@gertrude apache]# configtest
bash: configtest: command not found
[root@gertrude apache]# ./bin/apachectl configtest
Syntax error on line 207 of /usr/lib/apache/conf/httpd.conf:
Cannot load /usr/lib/apache/libexec/libphp4.so into server: libmysqlclient.so.6:
n shared object file: No such file or directory
[root@gertrude apache]#
Any help very gratefuly received!!
Russ Michell (APU Webteam)
--------------------------------------------
"Believe nothing - consider everything"
Russ Michell (APU webteam)
r.j.michell@anglia.ac.uk
ext 2331