Re: problems with a postgres connection script
| From: | Lars Torben Wilson | Date: | Tue, 07 Nov 2000 22:30:36 +0000 |
| Subject: | Re: problems with a postgres connection script | ||
| References: | 1 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-24213@lists.php.net to get a copy of this message | ||
Martin A. Marques writes:
> Hi I have this script which has problems connecting to the postgres backend.
> Postgres is running and PHP can see. I have IMP (webmail) working with
> Postgres on that server OK. This is the output I get on the apache error log:
>
> [Tue Nov 7 19:18:22 2000] [error] PHP Warning: Unable to connect to
> PostgreSQL server: connectDBStart() -- unknown hostname: ultra31,
^^^^^^^^^^^^^^^^^^^^^^^^^
I'm guessing it's not finding any hosts named 'ultra31'. Is ultra31
the name of the local machine? If so, try 'localhost' instead. Perhaps
you need to fully qualify the host name yourself?
> in /space/http/html/pruebas/cargar.php on line 2
> [Tue Nov 7 19:18:22 2000] [error] PHP Warning: Supplied argument is not a
> valid PostgreSQL link resource in /space/http/html/pruebas/cargar.php on line
> 4
>
> Any ideas?
--
+----------------------------------------------------------------+
|Torben Wilson <torben@php.net> Netmill iTech|
|http://www.coastnet.com/~torben http://www.netmill.fi|
|Ph: 1 250 383-9735 torben@netmill.fi|
+----------------------------------------------------------------+