Install PHP4.0.1pl2 above Solaris8 for SPARC

From: Date: Mon, 13 Nov 2000 03:31:25 +0000
Subject: Install PHP4.0.1pl2 above Solaris8 for SPARC
Groups: php.general 
Request: Send a blank email to php-general+get-24906@lists.php.net to get a copy of this message
Dear: I meet a question when I start httpd . My machine is Sun U5.My OS is Solaris8 for sparc. My DB is Oracle8i.Web server is apache1.3.9 I install php4.0.1pl2 with DSO mode.My Compiler is gcc-28~1. I install apache as following: a ./configure --prefix=/usr/local/apache --with-layout=GNU --enable-shared=max --enable-module=most b make c make install 1:I install php as following order: a ./configure --with-apxs=/usr/local/apache/sbin/apxs --with-mysql --enable-versioning --enable-sigchild b make c make install when I execute ./apachectl start, The following infomation list: Syntax error on line 238 of /usr/local/apache/etc/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: ld.so.1: /usr/local/apache/sbin/httpd: fatal: relocation error: file /usr/local/apache/libexec/libphp4.so: symbol __muldi3: referenced symbol not found ./apachectl start: httpd could not be started 2:I install php as following order: a ./configure --with-apxs=/usr/local/apache/sbin/apxs --with-mysql --enable-versioning --with-oracle=/usr/local/OraHome1 --with-oci8=/usr/local/OraHome1 --enable-sigchild b make c make install when I execute ./apachectl start, The following infomation list: Syntax error on line 238 of /usr/local/apache/etc/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: ld.so.1: /usr/local/apache/sbin/httpd: fatal: relocation error: file /usr/local/apache/libexec/libphp4.so: symbol __xxx: referenced symbol not found ./apachectl start: httpd could not be started xxx means a word. Could you help me? Worried LGB ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ¡°200¼ÒÁ¬ËøÍøÕ¾£¬ÈÃÑÛ¾¦³¢³¢ÏÊ¡± http://www.chinese.com ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 163µç×ÓÓʾ֣¬¸øÄú¸üÍêÃÀEmail·þÎñ£¡ http://www.163.net ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

« previous php.general (#24906) next »