RE: [PHP] Install PHP4.0.1pl2 above Solaris8 for SPARC
| From: | Henrik Johansson | Date: | Mon, 13 Nov 2000 08:30:27 +0000 |
| Subject: | RE: [PHP] Install PHP4.0.1pl2 above Solaris8 for SPARC | ||
| Groups: | php.general | ||
| Request: | Send a blank email to php-general+get-24927@lists.php.net to get a copy of this message | ||
Hi LGB!
I recognize this problem as beeing related to an issue using a DSO-capable
httpd-binary, as
my attemts to get this kind of setup running myself, have resulted in the
same error. Lack of time
made me revert to the old static compilation-scheme with the php-module tied
to it at compilation-time.
Consequently, the problem is more likely to be a configuration-tweak and
shouldn´t be too
much a head-ache; most webserver-admins have mastered this and there are
many well written
documents out there. I pleage I´ll get there too in time.
Best of Luck,
Henrik J!
> ----------
> From: wwwlgb@163.net[SMTP:wwwlgb@163.net]
> Sent: den 13 november 2000 04:31
> To: php-general@lists.php.net
> Subject: [PHP] Install PHP4.0.1pl2 above Solaris8 for SPARC
> Importance: High
>
> Dear:
> I meet a question when I start httpd .
> My machine is Sun U5.My OS is Solaris8 for sparc. My DB is Oracle8i.Web
> server is apache1.3.9
> I install php4.0.1pl2 with DSO mode.My Compiler is gcc-28~1.
> I install apache as following:
>
> a ./configure --prefix=/usr/local/apache --with-layout=GNU
> --enable-shared=max --enable-module=most
> b make
> c make install
>
> 1:I install php as following order:
>
> a ./configure --with-apxs=/usr/local/apache/sbin/apxs
> --with-mysql --enable-versioning --enable-sigchild
> b make
> c make install
> when I execute ./apachectl start, The following infomation list:
> Syntax error on line 238 of /usr/local/apache/etc/httpd.conf:
> Cannot load /usr/local/apache/libexec/libphp4.so into server:
> ld.so.1: /usr/local/apache/sbin/httpd: fatal: relocation error: file
> /usr/local/apache/libexec/libphp4.so: symbol __muldi3: referenced symbol
> not found
> ./apachectl start: httpd could not be started
> 2:I install php as following order:
>
> a ./configure --with-apxs=/usr/local/apache/sbin/apxs
> --with-mysql --enable-versioning
> --with-oracle=/usr/local/OraHome1
> --with-oci8=/usr/local/OraHome1 --enable-sigchild
> b make
> c make install
>
> when I execute ./apachectl start, The following infomation list:
> Syntax error on line 238 of /usr/local/apache/etc/httpd.conf:
> Cannot load /usr/local/apache/libexec/libphp4.so into server: ld.so.1:
> /usr/local/apache/sbin/httpd: fatal: relocation error: file
> /usr/local/apache/libexec/libphp4.so: symbol __xxx: referenced symbol not
> found
> ./apachectl start: httpd could not be started
> xxx means a word.
> Could you help me?
>
> Worried
>
> LGB
>
>
>
>
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> ¡°200¼ÒÁ¬ËøÍøÕ¾£¬ÈÃÑÛ¾¦³¢³¢ÏÊ¡±
> http://www.chinese.com
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> 163µç×ÓÓʾ֣¬¸øÄú¸üÍêÃÀEmail·þÎñ£¡
> http://www.163.net
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>
>
>
>
>
>
> --
> PHP General Mailing List (http://www.php.net/)
> To unsubscribe, e-mail: php-general-unsubscribe@lists.php.net
> For additional commands, e-mail: php-general-help@lists.php.net
> To contact the list administrators, e-mail: php-list-admin@lists.php.net
>