Re: [SOLVED] Why I sart getting "Fatal error: Allowed memory size..." after php upgrade?
| From: | afan pasalic | Date: | Thu, 20 Dec 2007 19:10:00 +0000 |
| Subject: | Re: [SOLVED] Why I sart getting "Fatal error: Allowed memory size..." after php upgrade? | ||
| References: | 1 2 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-266189@lists.php.net to get a copy of this message | ||
Richard Lynch wrote:
> On Thu, December 20, 2007 11:37 am, afan pasalic wrote:
>> The hosting company I have one account (and several Add Domains)
>> upgraded php on the server from 4.4.7 to 5.2.5. After the upgrade I
>> start getting the error message:
>> Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to
>> allocate 122880 bytes) in...
>> on domains they use Gallery2 or are CMS (Joomla or Drupal) based.
>>
>> I contacted Tech. Support (Live Chat) and he told me I have to edit
>> memory limit in php.ini (for each domain).
>>
>> I asked him why it started so suddenly, did upgrade caused the problem
>> and I got as an answer: "Your scripts have begun to use more memory.
>> That would be the only reason for this error."
>> It doesn't make a sense to me and sounds like "let's blame something
>> else" type of answer.
>>
>> I'm going to edit php.ini though what if "client" doesn't have a clue
>> what's php.ini or how to do it?
>>
>> I would like to hear your opinion what caused the problem.
>> I'll edit php.ini, I'm not going to make a big deal of it, though, I
>> just want to know why it happened.
>
> PHP 5 uses more RAM than PHP 4, both to start up, and on a
> script-for-script basis.
>
> It has more features, more OO complexity, and uses more RAM, plain and
> simple.
>
> The PHP Dev Team increased the default/recommended memory limit from 8
> M to 16 M with the release of PHP 5.
>
> I think they even documented this change, but you'll have to dig that
> out for yourself.
>
> Your hosting company probably kept the old php.ini without realizing
> that they needed to read the docs and change it.
>
> ymmv
>
just talked to tech. support.
actually, they didn't upgrade the server I was on the moved me
completely to other server that use php5. they moved all my files -
original php.ini as well. :)
I'm going to to add domain in Addon Domains and then copy that php.ini
on other Addon Domains.
Thanks for help.
-afan