Re: Pass Variable Names to a Function
| From: | Richard Lynch | Date: | Tue, 05 Feb 2008 01:24:22 +0000 |
| Subject: | Re: Pass Variable Names to a Function | ||
| References: | 1 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-268695@lists.php.net to get a copy of this message | ||
function silly($var){
return isset($_SESSION[$var]) ? $_SESSION[$var] : '';
}
silly('foo');
On Fri, February 1, 2008 10:49 am, Bill Guion wrote:
> I would like to use a function to check to see if a session variable
> is set and return the session variable if it is set, and return blank
> if not. Something like
>
> function set_var($var)
> {
> echo "var = $var \n";
> if (isset($_SESSION['$var']))
> {
> return $_SESSION['$var'];
> }
> else
> {
> return "";
> }
> }
>
> And I would call the function with set_var($name) or set_var($phone).
> The problem is getting the function to use $var as a variable name,
> rather than a value. What am I missing, please?
>
> -----===== Bill =====-----
> --
>
> Diplomacy - telling your boss he has an open mind
> instead of saying he has a hole in his head.
>
> --
> PHP General Mailing List (http://www.php.net/)
> To unsubscribe, visit: http://www.php.net/unsub.php
>
>
--
Some people have a "gift" link here.
Know what I want?
I want you to buy a CD from some indie artist.
http://cdbaby.com/from/lynch
Yeah, I get a buck. So?