Re: Programming structures

From: Date: Sat, 24 Jun 2000 23:47:06 +0000
Subject: Re: Programming structures
References: 1  Groups: php.general 
Request: Send a blank email to php-general+get-2936@lists.php.net to get a copy of this message
alex <alex@quad.com.ar> wrote: > I would allways use the die() alternative, since it's much more readable > than the "if/else" solution. On the other hand, making your script die is > not so nice, for example I usually require() some footer.inc's at the end of > the scripts that wouldn't get executed with the die() before it. Nothing prevents you from designing your own die() function like function myDie($errormsg) { print "</table></table></table>Error: '$errormsg'"; require 'footer.inc'; exit; } -- Greetings from Troels Arvin, Copenhagen, Denmark

« previous php.general (#2936) next »