pgsql+apache module
| From: | Andy MacNamara | Date: | Fri, 08 Dec 2000 16:09:25 +0000 |
| Subject: | pgsql+apache module | ||
| Groups: | php.general | ||
| Request: | Send a blank email to php-general+get-29367@lists.php.net to get a copy of this message | ||
Hi,
I've got PHP4/Apache set up on Debian. Whenever I enable pgsql.so in my
php.ini, Apache won't serve me html pages anymore. It serves pdf files
fine, but html and php stuff doesn't work. In my apache error log file I
get "Child process XXXX died from segmentation fault" or something like
that. This goes away when I disable the pgsql.so, but then the pg_*
functions are disabled, obviously.
I checked for the pthreads thing mentioned in the FAQ for MySQL, but pgsql
is not linked against libpthreads. It is linked against my libc, though,
which is 2.2.
Any ideas?
Thanks,
Andy MacNamara