LDAP problems

From: Date: Thu, 18 Jan 2001 20:19:25 +0000
Subject: LDAP problems
Groups: php.general 
Request: Send a blank email to php-general+get-35430@lists.php.net to get a copy of this message
Here is my environment again: System Linux server@domain.com 2.2.5-15 #1 Mon Apr 19 22:21:09 EDT 1999 > i586 unknown > Build Date Sep 7 2000 > Configure Command './configure' '--with-apxs=/usr/local/apache/bin/apxs' ' > --with-config-file-path=/usr/local/apache/conf' '--enable-versioning' ' > --with-mysql' '--enable-ftp' '--with-gd=/usr/local/gd' ' > --enable-bcmath=yes' '--disable-debug' '--enable-memory-limit=yes' > ' > --enable-track-vars' ' > --with-openlink=/usr/local/odbc' ' > --with-ldap=/usr/local/openldap' > Server API Apache > Virtual Directory Support disabled > Configuration File (php.ini) Path /usr/local/apache/conf > ZEND_DEBUG disabled > Thread Safety disabled Here is my new problem: I tried a the new version of PHP (4.0.4pl1) and openldap (2.0.7) now. PHP configures fine and compiles fine. When I go to restart apache it gives me the following error: Syntax error on line 237 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: undefined symbol: ldap_value_free Does anyone know what this means or how to make it go away? The problem with having to compile everything in is now apache and php are down because of my ldap problem. It would be nice if it would start apache and php and give me a message that ldap is not installed. One bad apple/module should not spoil the whole bunch. Thanx in advance for any help, BEH

« previous php.general (#35430) next »