PHP won't allow Apache to start
| From: | Chris Boothe | Date: | Fri, 22 Dec 2000 19:50:51 +0000 |
| Subject: | PHP won't allow Apache to start | ||
| Groups: | php.general | ||
| Request: | Send a blank email to php-general+get-35947@lists.php.net to get a copy of this message | ||
Any ideas?
Normally NuSphere sets it up but it isn't installing PHP even though the
status says done.
Here is what you asked about,
[root@ /root]# httpd -la
Compiled-in modules:
http_core.c
mod_so.c
suexec: disabled; invalid wrapper /usr/sbin/suexec
[root@ /root]# ll httpd
m-rw-r--r-- 1 root root 0 Dec 21 15:22 httpd
Thanks,
Chris
Script done on Thu Dec 21 15:23:09 2000
----- Original Message -----
From: "jason davidson" <jdavidson@zworg.com>
To: "Chris Boothe" <cboothe@home.com>
Sent: Thursday, December 21, 2000 2:39 PM
Subject: Re: [PHP] Apache won't start because of new PHP installation.
> are you sure that httpd has php4 compileed into it...
> Apache/bin/ll httpd
> should give you a list of mods that are compiled into apache
>
> Chris Boothe wrote:
>
> > Here is the typescript of what I tried.
> >
> > Script started on Thu Dec 21 14:15:16 2000
> > [root@ apache]# apachectl start
> > Syntax error on line 239 of /usr/nusphere/apache/conf/httpd.conf:
> > Cannot load /usr/nusphere/apache/libexec/libphp4.so into server: shared
object not open
> > /usr/bin/apachectl start: httpd could not be started
> >
> > [root@ /etc]# cat ld.so.conf
> > /usr/X11R6/lib
> > /usr/kerberos/lib
> > /usr/lib
> > /usr/lib/sane
> > /usr/nusphere/apache/libexec
> > /home/php-4.0.4/libs
> >
> > [root@ /etc]# ldconfig
> >
> > [root@ /etc]# apachectl start
> > Syntax error on line 239 of /usr/nusphere/apache/conf/httpd.conf:
> > Cannot load /usr/nusphere/apache/libexec/libphp4.so into server: shared
object not open
> > /usr/bin/apachectl start: httpd could not be started
> > Script done on Thu Dec 21 14:16:34 2000
> >
> > I have searched the knowledge base and I tried to add the paths to
ld.so.conf and restart apache but it doesn't do anything.
> >
> > I had previously installed NuSphere bundle, but today I tried with the
new release of PHP but I am still having the same problem.
> >
> > What else could it be?
> >
> > Thanks,
> >
> > Chris Boothe
> > cboothe@home.com
>