Re: Odd problem

From: Date: Sun, 04 Feb 2001 02:31:17 +0000
Subject: Re: Odd problem
References: 1  Groups: php.general 
Request: Send a blank email to php-general+get-38052@lists.php.net to get a copy of this message
> Apache on Solaris 2.6, suEXEC, PHP 3.0.15 as a CGI (not mod_php). > I'm seeing this sort of thing in my Apache error logs. > > failed to open log file > fopen: Permission denied > [Thu Feb 1 04:28:33 2001] [error] [client 192.168.1.15] Premature end of script headers: /usr/local/mailman/cgi-bin/test.php3 > > test.php3 contains only: > > <?php header("Content-type: text/plain"); print "foo\n"; ?> Check what settings you have in httpd.conf and php.ini for logging errors -- It may be that PHP is trying to log an error (or just open a log in case there is an error) in a file that PHP doesn't have write access to... suExec may also be affecting it. If PHP is running as 'Joe' because of suExec, but you've become accustomed to telling PHP to log errors to a file 'Joe' can't write to, well, PHP is not going to be able to start once you throw suExec into the mix... -- Visit the Zend Store at http://www.zend.com/store/ Wanna help me out? Like Music? Buy a CD: http://l-i-e.com/artists.htm Volunteer a little time: http://chatmusic.com/volunteer.htm

« previous php.general (#38052) next »