Fw: can't start apache
| From: | Scott Wagner | Date: | Fri, 02 Mar 2001 12:16:31 +0000 |
| Subject: | Fw: can't start apache | ||
| Groups: | php.general | ||
| Request: | Send a blank email to php-general+get-42335@lists.php.net to get a copy of this message | ||
----- Original Message -----
From: Scott Wagner
To: php
Sent: Thursday, March 01, 2001 11:55 PM
Subject: can't start apache
Hi
I just installed mysql, apache and php4 on Linux Mandrake 7.0 from a cd I got with the book
"PHP Fast and Easy" After installing apache it seemed ok and started normally. But after
installing PHP4 I get the following error message when I try to start apache:
Syntax error on line 207 of httpd. config: cannot load /usr/apache_1.3.12/libexec/libphp4.so into
server: /usr/loca/apache_1.3.12/libexec/libphp4.so: undefined symbol: mysql_init
I used the following command to build php4:
./configure --with-mysql=/usr/local/mysql-3.22.32-pc-linux-gnu-i686/
--with-apxs=/usr/local/apache_1.3.12/bin/apxs
Including ./configure --activate-module=src/modules/modules/p in installation fails, saying
directories do not exist. Looking at previous output it appears that the modules have already been
activated.
Any hints in a newbie-friendly format would be greatly appreciated.
Thanks,
SW