PHP4 and Apache DBM authentication

From: Date: Fri, 09 Mar 2001 17:33:08 +0000
Subject: PHP4 and Apache DBM authentication
Groups: php.general 
Request: Send a blank email to php-general+get-43177@lists.php.net to get a copy of this message
I'm running apache 1.3.14+Ben-SSL/1.42 and php-4.0.4pl1 on a RedHat 6.1 linux box. I'm in trouble trying to authenticate users via mod_auth_dbm. Which DBA format should I use to generate user databases? I've tried with: 1) dba and gdbm format 2) dba and ndbm format 3) dba and db2 format I always read: ... [error] [client 192.168.0.11] (22)Invalid argument: could not open dbm auth file: /www/auth/passwd_db in apache logs. I've also tried with older deprecated dbm functions but the result is still the same. I guess the problem is that apache uses the "dbm" format. I've tried to build php whith the option: --with-dbm but I always get this error: configure: error: cannot find necessary header file(s) What shoul'd I do to compile this "dmb" support into php4 ? I've always thought that "dbm" was provided by "gdbm" but ... ------------------------------------------- Gabriele Carioli

« previous php.general (#43177) next »