Re: Anyone got the new Postgres 7.1 .rpms working?

From: Date: Tue, 24 Apr 2001 15:15:08 +0000
Subject: Re: Anyone got the new Postgres 7.1 .rpms working?
References: 1  Groups: php.general 
Request: Send a blank email to php-general+get-50085@lists.php.net to get a copy of this message
----- Original Message ----- From: "Geoff Caplan" <geoff@productivity.co.uk> To: "PHP General List" <php-general@lists.php.net> Sent: Tuesday, April 24, 2001 12:33 PM Subject: [PHP] Anyone got the new Postgres 7.1 .rpms working? > Hi > > I am trying to compile the latest version of PHP to work with the new > Postgres 7.1 on RedHat 6.2 > > I have installed the Postgres library, client and server .rpms without > any problems. > > Then in the php file /ext/pgsql/php_pgsql.h I have changed the > #include from <postgres.h> to <postgres_fe.h> as recommended. > > But my make is failing with the following error: > > php_pgsql.h:32: postgres_fe.h: No such file or directory > php_pgsql.h:33: libpq-fe.h: No such file or directory > php_pgsql.h:39: libpq/libpq-fs.h: No such file or directory > > So far as I can see, none of these files exist in my /usr tree. > > Is this a bug with the rpm or am I doing something dumb? My linux > skills are basic so any help would be much appreciated > > Geoff Caplan I had the same problem, and solved it by creating a symlink name postgres.h to fostgres-fe.h, and it is working great. In ypur postgres include dir do: ln -s postgres-fe.h postgres.h Meir Kriheli MKsoft computer systems 'There's someone in my head but it's not me" - Pink Floyd

« previous php.general (#50085) next »