Cannot load libphp4.so v4.0.1pl2
| From: | Jack Lauman | Date: | Wed, 05 Jul 2000 23:39:44 +0000 |
| Subject: | Cannot load libphp4.so v4.0.1pl2 | ||
| Groups: | php.general | ||
| Request: | Send a blank email to php-general+get-5100@lists.php.net to get a copy of this message | ||
I get the following error when I start Apache with php-4.0.1pl2:
Starting httpsd: Syntax error on line 246 of
/etc/httpd/conf/httpsd.conf:
Can't locate API module structure 'php4_module' in file
/etc/httpd/modules/libphp4.so: /etc/httpd/modules/libphp4.so: undefined
symbol: php4_module
Line 246 of httpsd.conf is:
LoadModule php4_module modules/libphp4.so
This line hasn't changed since previous versions.
This is my configuration:
./configure --with-apxs=/usr/sbin/apxs \
--enable-EAPI \
--enable-versioning \
--enable-calendar \
--with-config-file-path=/etc/httpd/conf \
--with-mm \
--with-mysql \
--with-iodbc=/usr/lib \
--with-unixODBC=/usr/lib \
--with-java=/usr/jdk118 \
--with-snmp \
--with-openssl \
--with-imagick \
--with-exif \
--with-zlib \
--with-GDBM \
--with-NDBM \
--with-dbase \
--with-filepro \
--with-ldap \
--with-xml \
--with-wddx \
--with-dom=/usr/lib/libxml.so \
--with-servlet=/usr/local/JSDK2.0 \
--with-java=/usr/jdk118 \
--with-ttf \
--with-tiff \
--with-jpeg \
--with-ftp \
--enable-track-vars \
--disable-debug
Anyone have any clues as to what would cause this?
Regards,
Jack