Re: Inoltra: Re2: [PHP] problem getting oracle to work with php4
| From: | David Robley | Date: | Wed, 23 May 2001 08:22:50 +0000 |
| Subject: | Re: Inoltra: Re2: [PHP] problem getting oracle to work with php4 | ||
| References: | 1 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-54003@lists.php.net to get a copy of this message | ||
On Wed, 23 May 2001 17:21, louigi600@gsmbox.it wrote:
> > > Starting httpd: Syntax error on line 872 of
> >
> > /etc/httpd/conf/httpd.conf:
> > > Cannot load /etc/httpd/lib/apache/libphp4.so into server:
> >
> > libclntsh.so.1.0:
> > > cannot open shared object file: No such file or directory
> > > [FAILED]
> >
> > libclntsh.so.1.0 is not in your library path /etc/ld.so.conf
> >
> > btw, make sure you linked both apache & php against libpthread
> > like libclntsh.so.1.0 is
> >
> > - Markus
>
> I fixed /etc/ld.so.conf
> I laso had a look at what you meant by that stuff about libpthread
> I'm not compiling apache coz I'm building DSO modules
> In PHP it looks like this library is linked by default:
> [root@linux php-4.0.5]# ./configure -help | grep pthreads
> --with-tsrm-pthreads Use POSIX threads (default)
>
> So I didn't put that in my config options ... I used:
> [root@linux php-4.0.5]# ./configure --with-mysql --with-apxs
> --enable-sockets --
> with-oracle=/mnt/ora_syb/ora/app/oracle/product/8.0.5
>
> I'm still getting the same error (see above).
> I even tried giving that lib 777 perms ... and linked it to where
> libphp4.so is ....
> but nothing ... still get the same error.
> What now ?
>
>
> Bye
> Dave
Did you remember to run ldconfig (as root) after changing your ld.so.conf?
--
David Robley Techno-JoaT, Web Maintainer, Mail List Admin, etc
CENTRE FOR INJURY STUDIES Flinders University, SOUTH AUSTRALIA
Are dog biscuits made from collie flour?