Re: Oracle Database keeps disconnecting - or something

From: Date: Fri, 22 Jun 2001 18:16:08 +0000
Subject: Re: Oracle Database keeps disconnecting - or something
References: 1  Groups: php.general 
Request: Send a blank email to php-general+get-54920@lists.php.net to get a copy of this message
Do you experience any other sort of problems other than those warnings? I mean, is anything wrong with the data? Normally, nothing should be wrong. I have seen the same messages (especially the "service handle not intitialized" one) in my server too. I have traced it to attemtps to close an already closed connection, as in $cone = OciLogon(...); ...stuff... OciLogout($cone); ...stuff... OciLogout($cone); Other than filling the logs, there doesn't seem to be any other problem. In my apps, everything works as it should. I tend to simply ignore them:-) -Stathis. "Taylor, Stewart" wrote: > > Hello, > > Just in case anyones got any ideas. > > I've been testing an application for a few weeks on a test server without > any problems. > After releasing it onto the live server, which is - according to the > administrator - setup exactly the same as the test server I've been running > into problems. > > Apparently the database seems to be disconnecting randomly see log file > extract below. > > I already had a application on the live server which has been working > perfectly for a year or so. Now the new application is live it is having > the same problem as well. > > The test version of the already live application is also on the same test > server and both databases on live and test are setup exactly the same way. > > > My administrator tells me that we have a license for unlimited connections > to the database etc.. > > My setup us > OCI8 Revision 1.96 > Oracle Version 8.1 > Apache Apache/1.3.11 > Redhat Linux 6.2 > php 4.0.2 > I'm also using phplib 7.2c to manage authentication/sessions and database > access. > > > I would be very grateful if anyone has got any suggestions > > > Regards, > > -Stewart > > > PHP Warning: failed to rollback outstanding transactions!: ORA-01012: not > logged on > in Unknown on line 0 > PHP Warning: failed to rollback outstanding transactions!: ORA-01012: not > logged on > in /usr/local/apache/phplib/auth.inc on line 0 > PHP Warning: failed to rollback outstanding transactions!: ORA-24324: > service handle not initialized > in /usr/local/apache/phplib/auth.inc on line 0 > PHP Warning: failed to rollback outstanding transactions!: ORA-24324: > service handle not initialized > in /usr/local/apache/phplib/auth.inc on line 0 > PHP Warning: failed to rollback outstanding transactions!: ORA-01012: not > logged on > in /usr/local/apache/phplib/auth.inc on line 0 > PHP Warning: failed to rollback outstanding transactions!: ORA-24324: > service handle not initialized > in /usr/local/apache/phplib/auth.inc on line 0 > PHP Warning: failed to rollback outstanding transactions!: ORA-24324: > service handle not initialized > in /usr/local/apache/phplib/auth.inc on line 0 > PHP Warning: failed to rollback outstanding transactions!: ORA-01012: not > logged on > in /usr/local/apache/phplib/session.inc on line 0 > PHP Warning: failed to rollback outstanding transactions!: ORA-01012: not > logged on > in /usr/local/apache/phplib/auth.inc on line 0 > PHP Warning: failed to rollback outstanding transactions!: ORA-24324: > service handle not initialized > in /usr/local/apache/phplib/auth.inc on line 0 > PHP Warning: failed to rollback outstanding transactions!: ORA-24324: > service handle not initialized > in /usr/local/apache/phplib/auth.inc on line 0 > PHP Warning: failed to rollback outstanding transactions!: ORA-01012: not >

« previous php.general (#54920) next »