Re: Problems upgrading APACHE/PHP/Mysql on remote server
| From: | Gerald Clark | Date: | Thu, 28 Jun 2001 13:42:23 +0000 |
| Subject: | Re: Problems upgrading APACHE/PHP/Mysql on remote server | ||
| References: | 1 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-55489@lists.php.net to get a copy of this message | ||
I don't really think you want a whole class on system design and software testing here.
If the problem is not with your PHP scripts, and your ISP appears
to be incompetent, get a different one.
M wrote:
Complete msg subject is "what can developer do when server provider upgrades any of Apache/PHP/Mysql softwares to newer version and this causes crash on already working transactions?" I am posting this also into MySql discussion list. I develop scripts for virtual stores, having probable market for my programs but.... there are some questions I am really concerned, and one of these questions is the subject of this message. I develop my scripts locally in Win98 environment (Apache / PHP / MySql installed) where check and debug my code, then when/if all is working ok, transfer scripts vis ftp to Linux rented remote server. I use another two remote servers (these are Linux free services) to check my scripts, ftping also scripts there to check if these are working ok before sendind to rented server. It happened to me that some transactions began to crash on remote rented server. Every time I ran a single PHP script to update database, appeared '1054 Out of Sync' MySql error, and after some minutes, appeared fatal 'Too many transactions...' error, then system halted and after 30 minutes it became alive again. These errors never happened into my local environment or free services I use to check scripts, so I wrote remote server asking what was happening. They answered for me 'oh no! now we are discovering, you were killing our server with your transactions all these days, we have lost some customeers because this, please dont run your scripts here to not be obligued cut Mysql services for you'. I passed all my sources to provider for they analyze what could be wrong with my code, but they found any abnormal or wrong code into. The fact is, every time one of my scripts executed, it spawned zillions of child tasks into apache server, these tasks opened by MySql. Nobody was able to discover where the problem was, because this script was equal (taking apart database fields) to other scripts which ran with no problem I ran PHPINFO on all environments I use and passed this info to server, they analyzed and said probably any combination of apache/php/mysql versions and/or/plus modules into their server was causing this problem, but since it was impossible to discover source of error, we agree I wouldnt run anymore my scripts on that server to not damage their services. Later, I rented another server provider and posted my scripts there. They are working with no problem til today. Now suppose I have lot of clients using my virtual store (and paying to me for this service), suddenly remote server upgrades apache or php or mysql (or install some new module into) and this causes crash into scripts. What can I do? I would like to hear from other people if this problems is (or else is not) a common one in Apache /PHP / Mysql environment. Also would like to know some suggestions: what to do when this happens? Thanks in advanced Miguel --------------------------------------------------------------------- Before posting, please check: http://www.mysql.com/manual.php (the manual)-- Gerald L. Clark gerald_clark@suppliersystems.comhttp://lists.mysql.com/ (the list archive)To request this thread, e-mail <mysql-thread77912@lists.mysql.com> To unsubscribe, e-mail <mysql-unsubscribe-gerald_clark=suppliersystems.com@lists.mysql.com> Trouble unsubscribing? Try: http://lists.mysql.com/php/unsubscribe.php