Oracle 8i + non perstistant database connections remaining open.

From: Date: Tue, 10 Jul 2001 08:32:32 +0000
Subject: Oracle 8i + non perstistant database connections remaining open.
Groups: php.general 
Request: Send a blank email to php-general+get-57114@lists.php.net to get a copy of this message
Hello, I'm using OCI8 Revision 1.96 Oracle Version 8.1 Apache Apache/1.3.11 Redhat Linux 6.2 php 4.0.2 I am connecting to my database using a non-persistant connection (ocilogin). My applications run with no problems during the day. However, at the end of the day there is about 20 database connections still open. This has caused a problem because when the database is shutdown to backup (overnight) and then restarted apache still retains the 20 connections. This means that when users begin using the applications again in the morning apache starts reusing the old connections plus creating some new ones and causes users to be intermittently logged out/refused access/random query failures etc.. The error messages logged when this happens are below: PHP Warning: failed to rollback outstanding transactions!: ORA-01012: not logged on PHP Warning: failed to rollback outstanding transactions!: ORA-24324:service handle not initialized A quick fix to this problem is to shutdown apache when the backup is run so all the connections are dropped/ Hovever, should these connections be remaining open in the first place? Has anyone got any ideas? -Stewart.

« previous php.general (#57114) next »