RE: [PHP] File Upload Size Limits

From: Date: Fri, 27 Jul 2001 06:41:09 +0000
Subject: RE: [PHP] File Upload Size Limits
References: 1  Groups: php.general 
Request: Send a blank email to php-general+get-59880@lists.php.net to get a copy of this message
I once had the same problem in a similar environment, but I never worked on it to fix it because it was sufficient for the given purpose. Later, I moved the script 1:1 (including php.ini) to a server running caudium as web server software and the problem was gone... Huh? >Did anyone have any thoughts on this? I can upload an 8 MB file, but after >that the upload fails. > > >I am running PHP 4.0pl1 with Apache 1.3.14 on RedHat Linux 7.1. I am trying >to do a file upload from the users PC to my web server. If I do a small >file, the transfer goes fine. If I do a large file (> 50 MB), the transfer >fails saying either the file was not available for reading or my script just >bombs out. I need to be able to have people upload large files. I have >changed the setting in php.ini to upload_max_filesize = 100M. > >Do I also need to change the following entries in php.ini? > max_execution_time = 60 > memory_limit = 8M > >Is this an apache limit? I'm not sure what to do with this as I really need >to be able to transfer large files. mit freundlichen Gruessen / yours sincerely Gunther E. Biernat Web Application Engineer ______________________________________________________________ RealNetworks GmbH Tel.: +49-40-415204-24 Weidestraße 128 Fax.: +49-40-415204-11 22083 Hamburg Mail: GEBiernat@real.com Germany URL : http://de.real.com ______________________________________________________________

« previous php.general (#59880) next »