RE: [PHP] URGENT!!! Can't start Apache with php4 and mysql

From: Date: Thu, 02 Aug 2001 14:00:21 +0000
Subject: RE: [PHP] URGENT!!! Can't start Apache with php4 and mysql
Groups: php.general 
Request: Send a blank email to php-general+get-60901@lists.php.net to get a copy of this message
> -----Original Message----- > From: Richard Kurth [mailto:rkurth@pacifier.com] > Sent: Thursday, August 02, 2001 5:36 AM > To: php > Subject: [PHP] URGENT!!! Can't start Apache with php4 and mysql > > > I have read the archives for this problem but I can't seam > to fix it. This is on a RedHat 7. I get this error when I > try to start Apache > > Starting httpd: Syntax error on line 256 of /etc/httpd/conf > /httpd.conf: Cannot load /etc/httpd/modules/libphp4.so into server: > libmysqlclient.so.10: cannot open shared object file: No such file > or directory > > What I have read is to add the path to libmysqlclient.so.10 to the > /etc/ld.so.conf file and then run "ldconfig". at root > > I did this but ldconfig does not run. I keep getting No such > file or directory If it's not in your normal search path, you might nead to provide the full path to the ldconfig program. I'm not sure where it normally lives on a Redhat system, but on my FreeBSD box, it's in /sbin. An alternative, of course, if you can't get things working the other way, is simply to copy libmysqlclient.so.10 to one of the locations that was already in your ld.so.conf (that is, somewhere that ld already knows about)... --- Mark Roedel | "The most overlooked advantage to owning a Systems Programmer | computer is that if they foul up there's no LeTourneau University | law against whacking them around a little." Longview, Texas, USA | -- Owen Porterfield

« previous php.general (#60901) next »