Might just be a typo, but...

From: Date: Sat, 01 Sep 2001 08:18:33 +0000
Subject: Might just be a typo, but...
Groups: php.general 
Request: Send a blank email to php-general+get-65561@lists.php.net to get a copy of this message
Hey, you people are great. 5 reasonable answers to a 1 silly problem within the hour. I'll exploit your goodwill. Here's the next one, this is about objects (in finnish): class Example { var $list; // Here I set the problem var $hinta; var $määrä; function Example() { $hinta = 0; $määrä = 0; $list = array(); // Initialised } function addToExample($object) { array_push($this->list, $object); // I've been over it a hundred times, but... } } when I call the function instanceOfExample->addToExample($object) I get: Warning: First argument to array_push() needs to be an array in xxx on line xx I know what this means, I also 'know' that there should not be any mistakes in that code. Mebbe a peculiarity I don't know of? Thanks - jon

« previous php.general (#65561) next »