PHP4 and Apache 1.3.20 DSO mode not working?

From: Date: Sun, 02 Sep 2001 16:52:56 +0000
Subject: PHP4 and Apache 1.3.20 DSO mode not working?
Groups: php.general php.install 
Request: Send a blank email to php-general+get-65651@lists.php.net to get a copy of this message
I'm running RedHat Linux 7.0+ and trying to get PHP 4.0.6 working with Apache 1.3.20 as a DSO. These are the most recent stable versions. I'm compiling the sources, the compiles finish with no errors and I get a libphp4.so file. Has anyone been able to compile these versions of Apache and PHP4 and be able to run PHP4 as a DSO? I don't see how it can be done. Has anyone been able to do this successfully? Apache won't load the PHP module, it complains that its "garbled" and maybe isn't really a DSO module. When I look at the Apache source it appears to be expecting a MODULE_MAGIC_COOKIE field in the "module" structure of a DSO, if it doesn't see this then the load will fail. Searching around through the PHP4 code I don't see anyplace where it is referencing MODULE_MAGIC_COOKIE. Did the Apache module structure change at some point and the PHP code not retain compatibility? Maybe I should try backing up to an earlier revision. Can someone suggest versions of Apache/PHP that do definitely work together?

« previous php.general (#65651) next »