PHP module unloadable

From: Date: Tue, 11 Sep 2001 08:46:46 +0000
Subject: PHP module unloadable
Groups: php.general 
Request: Send a blank email to php-general+get-66879@lists.php.net to get a copy of this message
I'm having a problem building a loadable PHP module with mysql support. without mysql support, there's absolutely no problem. the module appears to load correctly, until you start apache, at which point I receive: Syntax error on line 227 of /usr/www/conf/httpd.conf: Cannot load /usr/www/libexec/libphp4.so into server: /usr/www/libexec/libphp4.so: undefined symbol: uncompress I am running PHP's configure as: cd ../${php} ./configure --enable-inline-optimization \ --prefix=${instdir} \ --with-config-file-path=${instdir}/conf \ --with-pgsql \ --with-regex=php \ --with-gettext \ --enable-magic-quotes \ --enable-shmop \ --enable-trans-sid \ --enable-sockets \ --enable-sysvsem \ --enable-sysvshm \ --enable-versioning \ --enable-memory-limit \ --with-apache=../${apache} \ --enable-wddx \ --without-zlib \ --with-pgsql \ --with-mhash \ --with-imap || exit 1 # --with-mysql=/usr || exit 1 (last two lines changed to --with-imap \ --with-mysql=/usr || exit 1, for a module that fails as described above). I'd greatly appreciate any help in tracking this problem down. Kevin Way

« previous php.general (#66879) next »