Re: Re: Ramesus HELP ! Fwd: [PHP] mail() ERROR - WHY, WHY, WHY

From: Date: Wed, 12 Sep 2001 08:31:07 +0000
Subject: Re: Re: Ramesus HELP ! Fwd: [PHP] mail() ERROR - WHY, WHY, WHY
References: 1 2  Groups: php.general 
Request: Send a blank email to php-general+get-67018@lists.php.net to get a copy of this message
Hello Richard, Tuesday, September 11, 2001, 10:07:53 PM, you wrote: RL> Did anybody disable the mail() function in PHP? RL> What did you put in php.ini to call sendmail? RL> Are there any error messages in your Apache logs? RL> Re-posting with Rasmus' name is probably not particularly useful... RL> -- RL> WARNING richard@zend.com address is an endangered species -- Use RL> ceo@l-i-e.com RL> Wanna help me out? Like Music? Buy a CD: RL> http://l-i-e.com/artists.htm RL> Volunteer a little time: http://chatmusic.com/volunteer.htm RL> ----- Original Message ----- RL> From: Badger <badger@pongo.org> RL> Newsgroups: php.general RL> To: <php-general@lists.php.net> RL> Sent: Monday, September 10, 2001 1:34 PM RL> Subject: Ramesus HELP ! Fwd: [PHP] mail() ERROR - WHY, WHY, WHY >> This is a forwarded message >> From: Badger <badger@pongo.org> >> To: php-general@lists.php.net >> Date: Monday, September 10, 2001, 12:23:54 AM >> Subject: [PHP] mail() ERROR - WHY, WHY, WHY >> >> ===8<==============Original message text=============== >> Hello , >> >> >> I drowing here and need a life-ring! I have a site relying heavily on >> e-mail registration, forums, etc. and mail() is broken in my php >> install. I've been using an smtp server other than sendmail, but >> based on recommendations I have removed that smtp server, removed php, >> installed sendmail, reinstalled php, and php still complains that >> "Warning: mail() is not supported in this PHP build" and sendmail is >> clearly in my /var/lib/php.ini sendmail_path and the location is >> correct. I can send mail from the command line, but not via php's >> mail() >> >> Need Heeeeeelp! real bad. >> >> (beg, beg) >> -- >> Best regards, >> Badger mailto:badger@pongo.org >> >> >> -- >> PHP General Mailing List (http://www.php.net/) >> To unsubscribe, e-mail: php-general-unsubscribe@lists.php.net >> For additional commands, e-mail: php-general-help@lists.php.net >> To contact the list administrators, e-mail: php-list-admin@lists.php.net >> >> ===8<===========End of original message text=========== >> >> I am desperate to get this working. If anyone can tell me a way to >> troubleshoot this problem, I'll be happy to pursue it myself. I am >> running the RedHat 7.1 distribution of Linux, Apache 1.3.20, php >> 4.0.6, and sendmail-8.10.11. The Apache and php are src builds using >> tarballs and the sendmail is an rpm - I am only using sendmail to >> troubleshoot the problem, but I will eventually use dmail as my smtp >> server. All the above servers are on the sam machine. >> >> I have turned logging on in my php.ini, but the mail() error does not >> get written to the log file I specified, only to the Apache error log >> - but the error is the same as that displayed in my browser when php >> tries to call mail() "Warning: mail() is not supported in this PHP build" >> >> I've tried everything I can think of and recommendations from this >> list... >> >> I have removed php, removed sendmail, reinstalled sendmail, >> reinstalled php: >> >> here is my php build: >> >> ----------------------------------------- >> >> CPPFLAGS=-I/usr/local/include >> LDFLAGS=-L/usr/local/lib >> ./configure --prefix=/usr/local \ >> --with-apache=/usr/local/src/Apachetoolbox-1.5.38/apache_1.3.20 \ >> --enable-exif \ >> --enable-track-vars \ >> --with-calendar=shared \ >> --enable-safe-mode \ >> --enable-magic-quotes \ >> --enable-trans-sid \ >> --enable-wddx \ >> --enable-ftp \ >> --with-gd="/usr/local" \ >> --with-zlib \ >> --enable-gd-native-tt \ >> --with-t1lib="/usr/local/lib/php/t1libs" \ >> --with-jpeg-dir="/usr/local" \ >> --with-png-dir="/usr/local" \ >> --with-zlib-dir="/usr/local" \ >> --with-ttf \ >> --with-freetype-dir="/usr/local" \ >> --with-imap=/usr/local \ >> --with-mhash=/usr/local \ >> --with-mcrypt=/usr/local \ >> --with-unixODBC=/usr/local/unixODBC \ >> --with-mysql \ >> -------------------------- >> >> My php.ini is i the proper location and chnges get reloaded after >> reloading Apache - verified by phpinfo(). Here is the pertinent area >> of my php.ini file: >> >> --------------------------- >> >> sendmail_path = /usr/sbin/sendmail -t -i >> >> ------------------------- >> Here are others that I've tried in my php.ini file: >> >> ---------------------------------------- >> sendmail_path = /usr/sbin/sendmail >> --------------------------------------- >> >> sendmail_path = /usr/sbin >> -------------------------------------- >> >> sendmail_path = ".:/usr/sbin/sendmail -t -i" >> >> -------------------------------------- >> >> sendmail_path = ".:/usr/sbin/sendmail" >> >> >> ---------------------------------------- >> >> sendmail_path = ".:/usr/sbin" >> -------------------------------------- >> >> ;sendmail_path = (default) >> >> -------------------------------------- >> >> >> I still get the mail() error >> >> >> Please help me figure this one out. >> >> -- >> Best regards, >> Badger mailto:badger@pongo.org >> I have explained "everything" in much more detail than you can get from most posters to this list and was suprised that you (thank you) are the only one that even cared to respond - I must sound like a bumbling pathetic idiot to everyone else on the list...even though I have made my share of contibutions to this list in the past. Anyway, problem solved and thanks again for your input. -- Best regards, Badger mailto:badger@pongo.org

« previous php.general (#67018) next »