error about sk_new_null with apache/php lib

From: Date: Wed, 12 Sep 2001 14:35:59 +0000
Subject: error about sk_new_null with apache/php lib
Groups: php.general 
Request: Send a blank email to php-general+get-67049@lists.php.net to get a copy of this message
Hi, in our case the error message > Syntax error on line 239 of /home/mmulsy/apache/etc/httpd.conf: > Cannot load /home/mmulsy/apache/libexec/libphp4.so into server: > ld.so.1: /home/mmulsy/apache/bin/httpd: fatal: relocation error: file > /home/mmulsy/apache/libexec/libphp4.so: symbol sk_new_null: > referenced symbol not found > ../apachectl start: httpd could not be started occured because the php was linked with the wrong version of openssl. Your cause might be different, but probably is again related to compiling in a different environment than running. For me, the following line to apachectl solved the problem. # ----- # the php binary on neptun:/home/mmulsy/apache is linked against an # on old openssl version, so LD_LIBRARY_PATH must be adjusted ---tom LD_LIBRARY_PATH="/usr/local/versions/openssl-0.9.6b/lib:$LD_LIBRARY_PATH " export LD_LIBRARY_PATH # ----- regards, Tom.

« previous php.general (#67049) next »