Re: Help - error loading PHP into Apache

From: Date: Wed, 03 Oct 2001 02:55:14 +0000
Subject: Re: Help - error loading PHP into Apache
References: 1  Groups: php.general 
Request: Send a blank email to php-general+get-69675@lists.php.net to get a copy of this message
You probably don't need mm if you're not using SSL... It's also possible that PHP isn't finding MM properly without jumping through whatever hoops it does for SSL... At any rate, you didn't get MM, I guess... You might have ended up with a lib_mm.so that you can AddModule in httpd.conf, but I don't think so... Check in PHP's "lib" (or is it ".lib"?) directory... -- WARNING richard@zend.com address is an endangered species -- Use ceo@l-i-e.com Wanna help me out? Like Music? Buy a CD: http://l-i-e.com/artists.htm Volunteer a little time: http://chatmusic.com/volunteer.htm ----- Original Message ----- From: Michael Champagne <mchampagne@capis.com> Newsgroups: php.general To: PHP General Mailing List <php-general@lists.php.net> Sent: Wednesday, September 26, 2001 10:48 AM Subject: Help - error loading PHP into Apache > Help! > > I'm trying to install a development Apache + PHP environment on the same > machine as our test environment (Apache + mod_SSL + PHP). I followed the same > procedure that I used to set up our test system (which works fine) and > everything compiles and builds fine. However when I try to start up Apache I > get: > > Syntax error on line 236 of /usr/local/apache/dev/conf/httpd.conf: > Cannot load /usr/local/apache/dev/libexec/libphp4.so into server: > /usr/local/apache/dev/libexec/libphp4.so: undefined symbol: mm_create > ./apachectl start: httpd could not be started > > The mm library was configured like this: > ./configure --disable-shared --prefix=/usr/local/mm > make > make test > make install > > Apache was configured like this: > EAPI_MM=/usr/local/mm \ > ./configure --prefix=/usr/local/apache/dev --enable-module=most \ > --enable-shared=max > > PHP was installed like this: > ./configure --with-apxs=/usr/local/apache/dev/bin/apxs --without-mysql \ > --with-oci8=/oracle --with-gd --with-mm=/usr/local/mm > > I have tried recompiling this several times with the same error message. The > only difference between this setup and the other Apache setup on this machine > is the other (working) one has mod_SSL installed and enabled. Does anyone see > what my problem is here? > > Thanks in advance for any replies, > > -- > Michael Champagne, Software Engineer > Capital Institutional Services, Inc. > wk: mchampagne@capis.com > hm: mchamp@texas.net > > > > ****************************************************************** > This communication is for informational purposes only. It is not > intended as an offer or solicitation for the purchase or sale of > any financial instrument or as an official confirmation of any > transaction, unless specifically agreed otherwise. All market > prices, data and other information are not warranted as to > completeness or accuracy and are subject to change without > notice. Any comments or statements made herein do not > necessarily reflect the views or opinions of Capital Institutional > Services, Inc. Capital Institutional Services, Inc. accepts no > liability for any errors or omissions arising as a result of > transmission. Use of this communication by other than intended > recipients is prohibited. > ******************************************************************

« previous php.general (#69675) next »