Upgrade Issues
| From: | Evan | Date: | Sun, 07 Oct 2001 02:51:37 +0000 |
| Subject: | Upgrade Issues | ||
| Groups: | php.general | ||
| Request: | Send a blank email to php-general+get-70265@lists.php.net to get a copy of this message | ||
I recently upgraded to PHP 4.06 from 4.02 and have encountered another possible problem.
I create a link to the mysql database with mysql_connect,
all future querys opt out of the link identifier with:
mysql_db_query([db name], [query]);
If the script makes too many querys, somewhere around 5 (I'm not sure), the link is dropped and
the mysql_db_query command appears to try and re-establish the link.
and the script returns the error:
Warning: Access denied for user: 'nobody@localhost' (Using password: NO) in
/home/httpd/html/distsupp/admin/security.inc on line 61
Warning: MySQL Connection Failed: Access denied for user: 'nobody@localhost' (Using
password: NO) in /home/httpd/html/distsupp/admin/security.inc on
line 61
Warning: MySQL: A link to the server could not be established in
/home/httpd/html/distsupp/admin/security.inc on line 61
This line of code is:
$result = mysql_db_query($distadmdb, $query) or error(mysql_error());
This didn't happen in 4.02. In fact, if I change back to 4.02 and reload the same page, I
don't get this problem. Is this behavior to be expected, is there a configuration option that
I should look for that sets the max querys per link?