Error starting Apache 1.3.22 with PHP 4.0.6.

From: Date: Wed, 17 Oct 2001 06:46:12 +0000
Subject: Error starting Apache 1.3.22 with PHP 4.0.6.
Groups: php.general 
Request: Send a blank email to php-general+get-71297@lists.php.net to get a copy of this message
Hello all I have just compiled and installed Apache 1.3.22 (with module support) onto a freshly installed Red Hat 7.1. I have also compiled and installed PHP 4.0.6. I have edited the httpd.conf script so that PHP parses .php files and also loads the PHP module like this: # Example: # LoadModule foo_module libexec/mod_foo.so
LoadModule php4_module        libexec/libphp4.so
However, when I check the configuration file with /usr/local/apache/bin/apachectl configtest I get the following error message: Syntax error on line 205 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: undefined symbol: uncompress Likewise, when I try to start Apache, I get the same error message. This message does not make sense to me :-( Line 205 is the LoadModule line above. I have installed this combination of web server and PHP many times on many different servers, but have never come across that particular error message. Would someone be able to explain to me what is going on and how I can successfully load the libphp4.so module? Thank you very much in advance Stefen Lars _________________________________________________________________ Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

« previous php.general (#71297) next »