php filling apache error log with copies of the server environment
| From: | Liam Hoekenga | Date: | Thu, 01 Nov 2001 00:11:00 +0000 |
| Subject: | php filling apache error log with copies of the server environment | ||
| References: | 1 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-73094@lists.php.net to get a copy of this message | ||
Hey -
My php installation is filling my apache error log with copies of the
piece of the environment that PHP knows as HTTP_SERVER_VARS. It seems to
be caused by imap functions.
<? phpinfo(); ?>
doesnt do it... but if i do
<? $mb = imap_open("{imap.blah.edu:143}INBOX", 'user', 'passwd');
?>
I get a bunch of:
REDIRECT_nokeepalive=1
REDIRECT_STATUS=200
REDIRECT_URL=/test.php
REMOTE_ADDR=x.x.x.x
REMOTE_HOST=mojojojo.blah.edu
etc...
in the apache error log.
I'm using PHP 4.0.6 (CGI), Apache 1.3.20, Solaris (SPARC) 2.6
Is there anyway to stop this? I've tried turning off error loggin in my
php.ini file, to no avail.
thanks
Liam