Re: PHP/Courier-IMAP and c-client library

From: Date: Tue, 29 Jan 2002 22:52:30 +0000
Subject: Re: PHP/Courier-IMAP and c-client library
References: 1  Groups: php.general 
Request: Send a blank email to php-general+get-82619@lists.php.net to get a copy of this message
For the archives: I found a fix for my problem. I want to be perfectly clear what my configuration is so that if anyone has this god-foresaken problem they can fix it. OS: Red Hat Linux 7.2 MTA: courier-mta IMAP: courier-imap I installed the UW c-client library and compiled it with "make lrh" I compiled PHP with these options: ./configure --disable-debug -enable-pic -disable-rpath --enable-inline-optimization --with-apxs=/usr/sbin/apxs --with-bz2 --with-curl --with-db3 --with-db2 --with-dom --with-gd --with-gdbm --with-gettext --with-openssl --with-png --with-zlib --enable-debugger --enable-ftp --enable-magic-quotes --enable-safe-mode --enable-sockets --enable-sysvsem --enable-sysvshm --enable-track-vars --with-mysql --with-pgsql --with-xml --with-imap=/usr/local/src/imap-2001a --with-imap-ssl On restarting Apache it complains with: [root@localhost php-4.1.1]# /etc/rc.d/init.d/httpd restart Stopping httpd: [FAILED] Starting httpd: Syntax error on line 261 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/libphp4.so into server: /etc/httpd/modules/libphp4.so: undefined symbol: gss_nt_service_name I added the following lines to my /etc/rc.d/init.d/httpd script in the start section right after the echo line: LD_PRELOAD=/usr/kerberos/lib/libgssapi_krb5.so export LD_PRELOAD If there is a more elegant way of doing this via Apache's build I'd love to know. Also, I will be documenting an entire howto on this configuration here: http://www.tonybibbs.com/courier-howto.html --Tony On Tue, 2002-01-29 at 16:26, Tony Bibbs wrote: > Ok, I have PHP 4.1.1 on RH7.2 and I'm running courier-mta and > courier-imap. I downloaded the UW c-client library and did the "make > lrh". I then do the following configure: > > ./configure --disable-debug -enable-pic -disable-rpath > --enable-inline-optimization --with-apxs=/usr/sbin/apxs --with-bz2 > --with-curl --with-db3 --with-db2 --with-dom --with-gd --with-gdbm > --with-gettext --with-openssl --with-png --with-zlib --enable-debugger > --enable-ftp --enable-magic-quotes --enable-safe-mode --enable-sockets > --enable-sysvsem --enable-sysvshm --enable-track-vars --with-mysql > --with-pgsql --with-xml --with-imap=/usr/local/src/imap-2001a > --with-imap-ssl > > Then the make and make install go as expected. > > I then go to restart Apache and I get: > [root@localhost php-4.1.1]# /etc/rc.d/init.d/httpd restart > Stopping httpd: [FAILED] > Starting httpd: Syntax error on line 261 of /etc/httpd/conf/httpd.conf: > Cannot load /etc/httpd/modules/libphp4.so into server: > /etc/httpd/modules/libphp4.so: undefined symbol: gss_nt_service_name > > Please help... > > -- > Tony Bibbs | Life is a moderately good play > tony@tonybibbs.com | with a bad 3rd act. > 515.554.8046 | -- Tony Bibbs | Life is a moderately good play tony@tonybibbs.com | with a bad 3rd act. 515.554.8046 |

« previous php.general (#82619) next »