Re: Funny stiff in my logs
| From: | David Robley | Date: | Tue, 12 Feb 2002 03:12:21 +0000 |
| Subject: | Re: Funny stiff in my logs | ||
| References: | 1 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-84346@lists.php.net to get a copy of this message | ||
In article <B88DA84E.11C17%lists@newgeo.com>, lists@newgeo.com says...
> Hello, I am running only php with apache on a OSX 10.1.2 machine, in my
> apache error log, I have some odd lines in there....
> statfs failed because: No such file or directory
>
> Here is a summarization of where I am at now....
>
> First I did a grep -r 'statfs\ failed' /
> To see if any files on the entire apache server had that line in it, if it
> did, I could see where any why it was reporting this to to apache log,
> nothing showed up.
>
> I thought maybe it was in a binary and I would not be able to read it with
> grep, so off to download the source :-)
>
> Got source on Perl, Php, Apache
> Grepped out all those, and nothing at all either.
>
> I ran tail on the error_log while watching the site requests, and I saw
> nothing that corresponds with the lines in the error logs.
>
> Generally, a apachectl graceful, will restart the server, and then, in about
> 15 seconds, I get 4 lines in the error_log
> statfs failed because: No such file or directory
> statfs failed because: No such file or directory
> statfs failed because: No such file or directory
> statfs failed because: No such file or directory
>
> Then nothing for a while, maybe 5 minutes, then a few more, sometimes more
> than 4, sometimes less.
>
> Had a few friends look into their error logs, all on OSX 10.1, and they also
> are having this as well. I am going to make a guess here, all apple OSX
> boxes are going to have this, any ideas where to go next?
If you do man statfs, you'll see that it is a function to return
statistics on a mounted filesystem. [NB I am not a C programmer!] That
being the case,it's probably called through a header file, rather than in
the actual code of whatever. It might be that apache is attempting to
determine whether a non-essential file exists, and hsppily going on its
way after finding that the file isn't there?
[Guessing here - corrections from knowledgable persons welcome] I can't
check statfs without rebooting this thing into Linux, but I'd hazard a
guess that the error message you are getting is returned by statfs, as
there is no log level in the message; apache error log entries seem to
have levels like [notice], [warn] etc.
So if it is just apache checking for the existence of something, I would
venture to say that it might be nothing to worry about, _if_ everything
else is working OK.
--
David Robley
Temporary Kiwi!