Safe mode/restricted directory file system operations

From: Date: Thu, 21 Feb 2002 18:44:44 +0000
Subject: Safe mode/restricted directory file system operations
Groups: php.general 
Request: Send a blank email to php-general+get-85757@lists.php.net to get a copy of this message
Apache server with PHP module Apache user is nobody:nobody Virtual user is user1:user1 in VirtualHost we have <VirtualHost ip.add.re.ss> DocumentRoot /www/user1 <Directory "/www/user1"> Options Indexes FollowSymLinks MultiViews AllowOverride All Order allow,deny Allow from all </Directory> php_admin_value upload_tmp_dir /www/user1/tmp php_admin_value open_base_dir /www/user1 </VirtualHost> All files in /www/user1 including the user1 direcrot are owned by user1:user1 Having problems with 1) file uploads into tmp... nobody not having permission to move them into the final location 2) symlinking directories within the /www/user1 tree eg. unlink("/www/user1/mylink"); symlink("mylink","/www/user1/NewDirToLinkTo"); Fails with permission denied to Unlink, or Link (if the link is manually deleted) Removed the safe mode restrictions on this particular virtual host to try and accomodate some of these tasks, but to no avail. drawing a blank now from looking at it so long. Ideas or suggestions appreciated. Dave

« previous php.general (#85757) next »